1.1

LESSON 1 – Starting TerraView
This lesson introduces TerraView software, presenting its main interface and usages.
TerraView executable, this document and the data files required to follow the tutorial
lessons

can

be

downloaded

from

TerraView

web

site

at

http://www.dpi.inpe.br/terraview.
TerraView is a viewer of geographical data stored in a TerraLib database. In addition to
visualization tools, TerraView provides a set of analysis tools. Figure 1.1 shows the
different parts of TerraView main interface.

Figure 1.1 – Main Interface.

As can be seen in Figure 1.1, TerraView main interface consists of 7 components that
will be described as the reader is guided through a set of examples and exercises.
Theses examples and exercises are designed to provide to the user a comprehension
of the main concepts of TerraView.

1.1 Database
TerraView creates and handles geographical databases in a DBMS – Database
Management System, such as MySQL or PostgreSQL. Data is stored according to the
data model proposed by TerraLib, a library of functions that supports TerraView. A
TerraLib/TerraView database can store both vector and raster data.
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Each session of TerraView allows the manipulation of one database. Therefore, the
first operation when starting TerraView is to create a new database or to connect to an
existing one.

1.1.1 Creating a New Database
In order to create a new database, you activate the Database user interface through
the shortcut icon

in the toolbar or through the File → Open Database... menu (see

Figure 1.2).

Figure 1.2 – Database User Interface (Create).

To create a new database, follow these steps:
1. Select Create option in Operation frame.
2. Select the DBMS in Database Type list. Observe that this interface changes
based on the chosen DBMS:
a. If you want to use Access DBMS, click on the Directory... button to
indicate where the new database will be stored.
b. If you want to use another DBMS with client-server architecture, it is
necessary to inform where the server is located (Host and Port) and
who the user is (User and Password).
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3. Choose a name for the new database and type it in the Database Name
field. In this tutorial, we will use ACCESS and will create a new database
named Tutorial, but it can be replicated in any of the DBMS currently
supported by TerraView.
4. Encoding: when this field is enabled, you may want to provide the new
database character encoding (e.g. latin1, UTF8), if the default encoding is
not desired. When you do not fill this field, the default encoding will be used.
This field is enabled when creating the database and using a few database
managers, e.g. PostgreSQL and PostGIS.
5. Click on OK button.
Creating a database means that a set of tables and their relationship are created.
Those tables and relationships will be later used by TerraView. After creating a
database, TerraView automatically connects to it.

1.1.2 Connecting to a Database
In order to connect to, or open, a database that has been already created, you should
activate Database interface through the shortcut icon

in the toolbar or through the

File → Open Database... menu. The interface shown in Figure 1.3 will be displayed.

Figure 1.3 – Database User Interface (Connect).
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To connect to an existing database, follow these steps:
1. Select Connect option in Operation frame.
2. Select a DBMS in Database Type list. Observe that this interface changes
based on the chosen DBMS:
a. If you use Access DBMS, search and select the database through
the Select Database button. In this case, the selected database is a
file with “.mdb” extension, and its name will be written in the
Database Name field.
b. If you use another DBMS with client-server architecture, it is
necessary to inform where the server is (Host and Port) and who
the user is (User and Password). After that, click Select Database
button, and the list of available TerraLib databases in the server is
displayed. Select a database in that list, and its name will be written
in the Database Name field.
3. Click on OK button.
Once a database is connected, it is ready to be populated and/or manipulated by
TerraView.

1.2 Importing Vector Data
This section describes TerraView importing procedures for vector data files in different
formats. Usually an importing operation will create a new information layer (or simply
layer) in a TerraLib database.

1.2.1 MID/MIF Format
The Districts.mif and Districts.mid files contain the data related to the districts of São
Paulo city, including their boundaries and descriptive attributes. The “.mif” and “.mid”
files are MAPInfo software interchange format.
To import this data you activate Import interface through the shortcut icon
toolbar or through File→Import Data menu (see Figure 1.4).
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Figure 1.4 – Import Interface.

In this interface, follow these steps:
1. Click File button to select the file. Change file type filter to MID/MIF files (see
Figure 1.5), select Districts.mif file, and click Open.

Figure 1.5 – File Types Filter.

2. Observe that the interface recognizes the data projection since MID/MIF format
contains this information.
3. If you want, change the recommended name of the layer that will be created in
Infolayer Name text field.
4. Choose how descriptive attributes of the districts (in MID file) and their
geometries (in MIF file) should be linked. Linking Attributes Table and
Geometries frame presents two linking options:
a. Automatic option indicates that TerraView will automatically create a
unique identity number for each district. This will be done considering
the district order within MID/MIF file. For instance, the first object will
receive the identity 1, the second, identity 2, and so on. This identity will
be shown in TerraView as a new attribute of the districts.
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b. Link Column option allows you to choose one of the existing attributes
(or columns) in the MID file to be used to identify a district. If you choose
this option, you must be sure that the chosen column does not contain
repeated values. In this case, choose the second option and the column
ID.
5. Click OK. The interface asks you to confirm the choice of step 4.

NOTE: The Encoding option may be used when import data use a character encoding
which is incompatible with the database character encoding. This occurs, for example,
with Latin1 and UTF-8 encodings. In general, it may be ignored. See more information
in the corresponding interface help.

Now a new layer appears in the Layers Tree, as shown in Figure 1.6.

Figure 1.6 – Layers Tree.

In order to display or manipulate a layer in TerraView, you must have a Theme built
from the layer in a View (Theme and View concepts will be explained further later). The
importing procedures can create Theme and View automatically by answering Yes to
the question shown in Figure 1.7.

Figure 1.7 – Confirm Automatic Display Interface.

Check Views Tree and Themes Tree and observe that a View and a Theme have
been created. Districts boundaries are displayed in Draw Area and their attributes are
shown in Grid Area (see Figure 1.8).
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Figure 1.8 – Result of Importing a MID/MIF File.

1.2.2 Shapefile Format
Now, you are going to import a second set of files that represent the subway system in
São Paulo city.

This set is known as Shapefile, an interchange format for ESRI

products. The format consists of three separated files: “subway_stations.shp”,
“subway_stations.dbf” and “subway_stations.shx”. In order to import these files, follow
the steps described in the previous section (do not forget to change the files type filter
in step 1). After that, the Import interface should be presented as shown in Figure 1.9.
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Figure 1.9 –Import Interface for the Subway system.

Optionally, shapefile format can also have a .prj file that describes data projection.
When this file exists, TerraView reads it and attempts to decode the projection
description. In cases when TerraView does not succeed the interface will indicate that
the projection wasn’t recognized.
Notice that the projection description for this data indicates “NoProjection/Spherical”,
which means that no Projection and Datum information could be retrieved from the
data file. Therefore, no geographical location can be associated to this data. If you
know the data projection you can inform it before starting the import by clicking the
Projection… button and setting the Projection parameters shown in Figure 1.10.
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Figure 1.10 – Interface to define projections.
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In this interface, set the parameters following the steps:
1. Select one of the available projections in the Projection list. In this case choose
UTM projection.
2. Observe that only the fields that describe the parameters that should be
informed for the chosen projection are enabled in the interface. In this case,
choose Zone 23 and observe that the origin longitude is automatically
displayed. Offset X and Offset Y fields are automatically filled with values
associated to this default south hemisphere, which are 500000 and 10000000,
respectively.
3. Select one of the available Datum in the Datum list. In this case, datum is
SAD69 (South American 1969)
4. Click OK.
Finish the import as in the previous example using the column ROTULO to identify the
objects. Now, answer No to the automatic display question (see Figure 1.7), and notice
that a new layer was created in Layers Tree (Figure 1.11), but data about the subway
system was not automatically displayed.

Figure 1.11 – Layers Tree with new layer.

Note: For a shapefile, it is possible to import more than one file in one operation. In
order to execute it, just choose the files to import in the file selection interface
(activated through File... button in Figure 1.9) using Ctrl key while pointing files with
the mouse. In this case, the automatic option (detailed in step 4 of item 1.2.1) will be
used to link attributes table and geometries for all resulting layers.

1.2.3 Tab/Geo Format
Now you are going to import a third set of files that represents some of the railway
system of São Paulo city. This file is in Geo/Tab format, an interchange file format of
SPRING software. This format is composed by two files: “railways_stations.geo” and
“railways_stations.tab”. Follow the steps described in the section 1.2.1 and do not
National Institute for Space Research - INPE – Image Processing Division

1.10
forget to change the filter of file types to show extensions “.geo”. This format also does
not contain information about the data projection, but you can manually inform it as
shown in section 1.2.2. In this case, inform the projection for this data: projection UTM
Zone 23, and Datum SAD69.
Again, answer No to automatic display question (see Figure 1.6) and observe the new
layer in Layers Tree (Figure 1.12).

Figure 1.12 – Layers Tree.

Import of geographical data represented as raster data will be explained in Lesson 5.
The next section presents some visualization operations and tools using the data
imported in previous sections.

1.3 ToolBar Icons
The main functionalities related to data visualization can be accessed through the icons
in the ToolBar shown in Figure 1.13. When the mouse moves over an icon, TerraView
shows a tooltip for the operation it executes. The operations are executed on the active
View and its themes, and some are related to the concepts of Active Theme and
Visible Themes which are explained later.

Figure 1.13 – TerraView ToolBar.

Some of the functionalities available through the toolbar are:
•

: Draws the visible themes of the active View. This icon is only enabled when
there is an active View and, at least a visible Theme in this View. Click on a
View name to turn it into an active one. Click on the box next to a Theme name
to turn it into a visible one.

•

: Activates cursor mode Pointer (its usage will be explained later).

•

: Activates cursor mode Zoom. This cursor allows you to select a region of
the draw area to be zoomed. Click a point on the draw area, keep the button
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pressed down, and move the mouse to select the region to be zoomed.
Release the button and the area will be redrawn.
•

Executes Zoom In operation. It magnifies the drawing based on a clicked
point (that will be centralized) and an increase factor defined by the user. A
default increase factor is provided, but if you want to change it, right click on
Draw Area and choose one of the available values, as shown in Figure 1.14.

Figure 1.14 – Increase or Decrease Zoom Factor.

•

: Executes Zoom Out operation. This operation is the opposite of Zoom In
and reduces the draw area.

•

: Activates cursor mode Pan. With this cursor you can move the data on the
Draw Area. Click on a point on the Draw Area, keep the button pressed down,
move the drawing to a new position, and release the button.

•

and

: Execute Previous Visualization and Next Visualization

operations, respectively.
•

: Executes Reset operation. This operation adjusts the draw area to show the
visible data in its entire extension.

•

: Activates cursor mode Distance. This cursor is responsible for calculating
the distance between two points on the Draw Area. Click on an initial point P1,
keep the button pressed down, and drag it to another point P2. This cursor
draws a circle in the Draw Area and shows the distance between P1 and P2 in
the Message Bar. This distance is calculated considering the current view
projection unit.

•

: Hides/shows Database Tree box.

•

: Hides/shows Views and Tree Themes box.

•

: Hides/shows Grid Area.

•

: Hides/shows Draw Area.

•

: Hides/shows Graphic Display Area.
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1.4 Selecting Objects
Each geographical object of a Theme is composed by geometries and descriptive
attributes. The geometries are shown in the Draw Area and the attributes are shown in
the Grid Area. In order to examine the link between geometries and attributes of
objects, follow the steps below:
1.

Activate Pointer Cursor

and click on an object on the Draw Area. Notice

that the geometry of the selected object is highlighted by changing its color in
the Draw Area and its attributes are highlighted in the Grid Area with the same
color. By default, TerraView moves the geometry of the pointed object to the
center of the Draw Area. To change this behavior, unselect the option
Centralize the Drawing of the Select Objects on the menu displayed when
right-clicking on the Draw Area.
2.

Clicking on a row of the Grid Area highlights the geometries associated to this
object in the Draw Area.

3.

Activate Information Cursor

and click on an object on the Draw Area. The

descriptive attributes of this object are presented in another interface, as
shown in Figure 1.15.

Figure 1.15 – Information Cursor.

4.

Activate Graphic Cursor

. Observe that this cursor is a rectangle, allowing

you to select all objects that intersect this rectangle (Figure 1.16).
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Figure 1.16 – Selecting Objects using the Graphic Cursor.

In order to change the cursor size, keep Alt key pressed down and move the
mouse until the desired size is created.
To change the cursor shape from rectangle to ellipse, right click on the Draw
Area and choose in Spatial Cursor Type → Ellipse. To change the spatial
operation of this cursor, right click on the Draw Area and choose one of the
spatial operations in Spatial Operation.
To remove the highlight or selection of an object, click on one of its geometries
or attributes. To remove the selection of all objects, click on Unselect Objects
icon

. Invert Selection icon

reverses pointed objects and non pointed

objects, as shown Figure 1.17.

Figure 1.17 – Invert Selection Icon.
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1.5 Exiting from TerraView
In order to exit from TerraView, select File → Exit menu. Everything that you have
created (Layers, Views and Themes) and done (Selection) is saved in the database. It
is not necessary to save explicitly before exiting from TerraView.
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