TerraLib and TerraView Wiki Page

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Both sides previous revision Previous revision
wiki:documentation:devguide:dependencies [2018/09/05 15:52]
marisa
wiki:documentation:devguide:dependencies [2018/09/17 10:02] (current)
marisa
Line 52: Line 52:
   * **Google Test and Google Mock** (Optional): Google Test and Google Mock are available from https://​github.com/​google/​googletest. Any recent version may be used.   * **Google Test and Google Mock** (Optional): Google Test and Google Mock are available from https://​github.com/​google/​googletest. Any recent version may be used.
  
-  * **Python** (Optional): Python is available from https://​www.python.org/​downloads. Use 3.6.6 version.+  * **Python** (Optional): Python is available from https://​www.python.org/​downloads. Use ''​python-3.6.6-amd64.exe''​.
  
 ===== Third party dependencies binaries for Microsoft Visual C++ for Windows ===== ===== Third party dependencies binaries for Microsoft Visual C++ for Windows =====
Line 64: Line 64:
 Microsoft Windows users that have downloaded one of the file [[http://​www.dpi.inpe.br/​terralib5-devel/​3rdparty/​bin|3rdparty zip]] must install the same version of Qt used to generate it, i.e., Qt5.10.1 (or Qt 5.4.1). Microsoft Windows users that have downloaded one of the file [[http://​www.dpi.inpe.br/​terralib5-devel/​3rdparty/​bin|3rdparty zip]] must install the same version of Qt used to generate it, i.e., Qt5.10.1 (or Qt 5.4.1).
  
-Also, the same lib Python version used must be installed. ​For example, for TerraView-5.4.0,​ lib Python-3.6.6.+Also, the same lib Python version used to generate the zip must be installed ​in your environmentIn this example ​''​python-3.6.6-amd64.exe''​.
  
 ===== Automatic Build of Third-party Dependencies with Shell Scripts (Linux/​MacOS/​Windows)===== ===== Automatic Build of Third-party Dependencies with Shell Scripts (Linux/​MacOS/​Windows)=====